Rücksprung aus laufenden Project Cars auf Desktop

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Rücksprung aus laufenden Project Cars auf Desktop

      Hi,

      ich habe ein nerviges Problem und wollte mal hören, ob das jemand kennt: Von Zeit zu Zeit mitten im Spiel (Project Cars 1/2) erfolgt ein Wechsel auf den Windows 10-Desktop. Wenn ich dann das Icon von Project Cars mit der Maus schnell anklicke, komme ich wieder in das laufende Spiel. Ein Rennen hat sich dann allerdings erledigt. Erst habe ich CrewChief die Schuld gegeben. Nachdem ich CrewChief allerdings eine Zeitlang deswegen nicht benutzt habe und das Problem weiter bestand, war klar das es daran nicht liegt.

      Ich habe absolut keinen Hinweis was die Ursache dafür. Wenn ich 2-3 Stunden Project Cars spiele, passiert das 1-2 mal in der Zeit.

      Ich habe eine nVidia GeForce GTX 950 im System und den Treiber habe ich aktualisiert. Letztens hatte ich es sogar mal, dass ich kein Rennen gefahren habe, sondern irgendwo in den Einstellungen des Spiels mich aufhielt, flupp und Desktop. Da ich die Tastatur und Maus definitiv nicht benutzt habe, wird das von irgendwas anderem ausgelöst. Ich habe ein relativ modernes System mit Windows 10 64Bit und 16 GB RAM. Da ich von Beruf IT-ler bin, ist das System in relativ gepflegtem Zustand.

      Als nächstest könnte ich mal alles an Hindergrundprogrammen ausfindig machen und beenden, allerdings habe ich diesen Effekt noch nie bei was anderem gehabt. Nur wenn Project Cars (1 oder 2) läuft, passiert das.

      Jemand 'n Idee? Mich würde, wie gesagt, es auch interessieren, ob das ein Einzelfall ist oder andere auch so ein Problem kennen.
    • Hi !

      Benutzt du nvidia Experience ? Wenn ja, mal deinstallieren. Das Problem hatte ein Freund von mir. Das fällt mir jetzt spontan ein als mögliche Ursache.
      "Probieren geht über Krepieren !"


      CPU: i5-4460 - Grafik: MSI GTX960 - MB: Gigabyte GA-Z97P-D3 - RAM: Crucial Ballistix 8GB

      OS: Win10 64bit - SSD: Kingston 60GB - HDD: Samsung 1TB - Case: beQuiet! Silent Base 800
    • Danke für den Hinweis. GraKa-Treiber habe ich schon aktualisiert, aber das Entfernen von nVidia Experience werde ich auf jedenfall noch mal im Hinterkopf behalten.

      Ich denke, ich habe die Lösung für mich gefunden:

      Seit 2 Tagen nicht einen Rücksprung mehr auf den Desktop und das hatte ich in letzter Zeit regelmäßig und häufig.

      Ich habe unter Windows 10 die "Spieleleiste" ausgeschaltet. Wenn die Einstellung aktiviert ist, kann man mittels Win-Taste + G so eine Leiste einblenden. Ich habe diese Funktion zwar nicht genutzt, aber das Problem bestand bei mir auch schon bei PC1 und deshalb habe ich sowieso an ein anderes Problem, wie z.B. GraKa oder sowas geglaubt, als das Project Cars in die Schuhe zu schieben. Zu finden ist das unter Einstellungen/Spielen.

      Ich hoffe mal das war's, da das Game vorher fast nicht mehr spielbar war. Diese Einstellung wird sicherlich bei vielen auch gesetzt sein, so gesehen bin ich noch nicht 100% davon überzeugt, dass das jetzt die Lösung war, aber faktisch habe ich seit ca. 5-6 Stunden spielen nicht einmal mehr den Effekt gehabt.

      **********
      Sa, nachts 5 Tage später:

      So hier noch mal mein Fazit nach zwischenzeitlichen Spielen über mehrere Tage (ca. 15 Stunden)

      Keinen Fehler mehr :D Nada, rien, nothing, niente

      Ich kann es kaum fassen, dass das die Lösung ist. Ich kann mich gar nicht daran erinnern, dass ich entspannt gefahren bin ohne zu befürchten, dass ich aus dem Rennen über diese Methode gekegelt werde.

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von virto ()

    • So ich bringe es jetzt hier zu Ende, weil der abschließende Stand nun doch ein anderer war.

      Exakt nach meinem letzten Beitrag habe ich wieder zwei Mal einen Wechsel auf den Desktop bekommen und da mir die Lösung schon generell etwas suspekt war, habe ich jetzt für mich eine bessere Erklärung: Ich habe in den Grafikeinstellung 4*Antialiasing auf 2* geändert und seit dem bin ich die Probleme los.

      Das war auch die Konfiguration als ich keine Probleme hatte und irgendwann habe ich das wieder zurück auf 4* gesetzt. Danach gab es dann auch wieder das Verhalten. So damit soll es jetzt genug sein...
    • Alles egal was ich mache, Problem ist wieder da.

      Monza in Führung liegen 11/15 Runden, danach auf Desktop geswitcht, über 1 Minute gebraucht um wieder ins Spiel zu kommen, letzter. :cry:
    • Den o.g. Hinweis werde ich mir anschauen ...

      Um es vorweg zu nehmen: Das Problem kam wieder und das regelmäßig. Aber ich habe momentan eine Lösung gefunden, die ggf. auch für andere Probleme herhalten kann (dazu später):

      Grundsätzlich habe ich den Ansatz getestet, das Spiel schon als Fenster laufen zu lassen, sodass wenn ein Switch-to-Desktop passiert, dann das Verhalten ein anderes ist. Das war ein Volltreffer, da in dem Fall zwar im Spiel ein Freeze von 1-2 Sekunden auftritt, aber das Zurückspringen auf den Desktop entfällt. Das Spiel läuft nicht im Vollbild und dadurch entsteht nicht dieser harte Fehler. Ich wechsel gar nicht erst auf den Desktop.

      Zusätzlich dazu habe ich weitere Startparameter entdeckt, nämlich

      -windowed -borderless

      (Werden unter den Steam-Eigenschaften des Spiels bei Startoptionen eingetragen.)

      Ich habe also in den Grafikeinstellungen den Fenstermodus auf "Ein" gesetzt und habe dann meine HD-Auflösung 1920*1280 60 Hz entsprechend gesetzt. Ohne die o.g. Parameter startet das Spiel als Fenster mit unschönen Balken, aber wenn die Start-Parameter gesetzt sind, ist kein Unterschied mehr erkennbar.

      Es gibt jetzt weitere Vorteile, wenn man das Spiel so startet: Ich kann auch unter Windows 10 1709 per Alt-TAB zwischen verschiedenden Prozessen (Fenstern) wechseln und auch ein Screenshot per Print-Taste funktioniert einwandfrei. (Das genannte waren Funktionen die zwischenzeitlich nicht klappten.)

      (Da will ich meine Hand nicht ins Feuer legen, dass das immer noch aktuelle Probleme sind, aber das war halt mein Stand vorher.)

      Fakt ist, dass ich jetzt wieder ohne wirkliche Probleme Rennen bestreiten kann und wenn dann mal das Problem im Rennen auftritt, verliere ich mal einen Platz, aber nicht das komplette Rennen. Die o.g. Lösung funktioniert schon seit einer Woche ohne Probleme und ein paar "Freezes" hatte ich zwischenzeitlich.

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von virto ()

    • Habe seit heute ein ähnliches Problem.

      Pcars2 startet, doch wenn ich einen Mausklick mache switcht es mich zurück auf den Desktop.
      Alle anderen Tastenbefehle funktionieren, nur Mausklick erzeugt das Problem.

      Hatte heute ein Windows 10 update, danach bestand dieses Problem.

      Gforce Experience war es nicht, hatte es deinstalliert.
      Spieleleiste hatte ich deaktiviert, war es auch nicht.
      Es waren auch alle Grafik und FFB Einstellungen weg.
      Lenkrad: Fanatec GT3 RS V2 Pedale: Fanatec CSR Elite - Sitz: Fanatec CSL Seat - PC: Acer Predator - GTX 1060 6Gb - I7 3770@4Ghz - 16GB Ram - Bildschirm: Samsung 48" FullHD TV - 2.Bildschirm: 22" Monitor + pCars Profiler Telemetrie
      Maus: Logitech G502 - Tastatur: Logitech G15 - Headset: SoundBlaster Rage Tactic 3D

      Second Screen: Samsung S5 + DashMeterPro + ProRacingDashboard + CrewChief

      Fahrer: Thorsten Kraffczyk
      www.SIMRACING UNITED
    • Die Probleme hören sich ähnlich ab, aber diese Effekte hatte ich nicht. Übrigens hat meine beschriebene Lösung wieder dazu geführt, dass ich ohne Probleme fahren kann. (Ich habe das nach dem Patch auch nicht mehr getestet, ob das Problem behoben ist.)

      Bei deinen Probleme würde ich mal im Dokumente-Verzeichnis schauen, ob da im Verzeichnis C:\Users\...\Documents\Project CARS 2 überhaupt alle config-Dateien mit durch das 1709-Update übernommen wurden.

      Schau mal auf das Datum der Dateien "ffb_custom_settings.txt" und "graphicsconfigdx11.xml", bzw, ob die überhaupt da sind. So wie ich das an anderer Stelle gelesen habe, sind das zentrale Konfigurationsdateien für FFB und Grafik wie die Namen das schon sagen.
    • Zusätzlich dazu habe ich weitere Startparameter entdeckt, nämlich

      -windowed -borderless

      (Werden unter den Steam-Eigenschaften des Spiels bei Startoptionen eingetragen.)

      leide habe ich das gleiche Problem seit ein paar Tagen.
      Was ich nicht finden kann ist die o.g. Einstellung ( windowed - borderless)
      kannst Du mir da bitte nochmal helfen, wo das genau zu finden ist.
      Das Spiel bleibt immer noch hängen, also friert ein und ich muss dann eine Tastenkombination drücken?

      Vielen Dank für Hilfe
    • Moin :)

      - öffne den Steam-Client (Register "Bibiliothek")
      - wähle Project CARS 2 mit der rechten Maustaste aus, sodass du das Kontextmenü erhältst
      - dort wählst du das untersten Menüpunkt "Eigenschaften" aus
      - es geht dann eine Maske auf, in der du im Register "Allgemein" den Button "Startoptionen festlegen..." betätigst
      - in der dann sich öffnenen Input-Box (Startoptionen - Project CARS 2) gibst du die genannten Parameter -windowed -borderless ein.
      - OK drücken, fertig

      Bitte achte darauf, dass in den Grafikeinstellungen von Project CARS der Fenstermodus auf "Ein" gesetzt wurde. In dem Zusammenhang wird dann auch die Auflösung definiert (bei mir HD-Auflösung 1920*1280 60 Hz).


      Meine Probleme waren dann behoben, da ich nach der Umstellung nie im echten Fullsreen-Modus spiele. Ist es dann so, dass das Spiel dann gar nicht mehr läuft oder noch im Hintergrund und du dann nur wieder hinkommen musst?