Telemetry Reader 2.0

  • [INFO]
  • pCARS 1

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Telemetry Reader 2.0

    Moin,
    da die neue App bisher recht stabil laeuft, hab ich mich mal daran gemacht den Reader
    ebenfalls zu ueberarbeiten.
    Das ganze natuerlich sowohl optisch, als auch was die Funktion und Stabilitaet angeht.
    Erstmal hab ich mich allerdings der Optik bzw. dem Aufbau gewidmet und
    den Style enstprechend an die Homepage und der App angepasst, damit das alles aehnlich aussieht
    und die Optik sich ueberall durchzieht.

    Dazu kamen bereits erste Aenderungen der Funktion einher:
    - 3 feste Geraete getrennt voneinander einstellbar
    - Die Optionen fuer IP, Port und Verzoegerung werden nun pro Geraet festgelegt
    - Das erlaubt z.B. ein Geraet mit wichtigen Infos zu priorisieren, um die Last soweit wie noetig verringern zu koennen
    - Die Geraete 2 und 3 sind komplett deaktivierbar, wenn nicht genutzt
    - Jedes einzelne Geraet laesst sich per Button pausieren, da nur im pausierten Zustand oder ohne aktives Spiel die Einstellungen geaendert werden koennen
    - Dazu kommen im Hintergrund bessere Lastverteilung, um etwaigen Performanceproblemen direkt vorzubeugen

    So hier mal noch ein Bild zum Vergleich zwischen 1.6 und 2.0:
    barzmobilesolutions.de

    Gaming and developing on:
    CPU: Intel i7 6700K | RAM: 32GB DDR4 | Graphics: Palit SuperJetstream GTX980 Ti | Storage: 2x512GB SSD
    Mobile development on:
    MacBook Pro 15,4"
    Racing Equipment:
    Wheel: G25 | Pedals: Fanatec Elite
    Testdevices for App development:
    Sony Xperia Z2 | Sony Xperia Z3 Tablet Compact | Nexus 9 | HTC Desire Z | iPodTouch 4G | iPad Air 2
  • Download Link? :P
    Mobo: ASUS X99-E WS | CPU: Intel Core I7 5930K @ 4,5 GHz | GPU: Nvidia GTX 1080ti | RAM: 32GB DDR4 2400 | PSU: be quiet! Dark Power Pro P10 1200W
    Cooling: Custom watercooled CPU and GPU | HDD: 2 x Samsung 256 GB SSD | OS: Win10 64bit | Wheel: CSW V2 + Heusinkveld HE pro + TH8RS | Monitor: LG 34UM65

    Kein Support per PN oder E-mail! Anfragen bitte im Forum, dann haben alle was davon!
  • Ohne Funktion dahinter ist es bisher nur eine schoene Huelle ;)
    Sobald ich eine funktionierende Variante habe gibts die hier auf jeden Fall zum Testen.
    barzmobilesolutions.de

    Gaming and developing on:
    CPU: Intel i7 6700K | RAM: 32GB DDR4 | Graphics: Palit SuperJetstream GTX980 Ti | Storage: 2x512GB SSD
    Mobile development on:
    MacBook Pro 15,4"
    Racing Equipment:
    Wheel: G25 | Pedals: Fanatec Elite
    Testdevices for App development:
    Sony Xperia Z2 | Sony Xperia Z3 Tablet Compact | Nexus 9 | HTC Desire Z | iPodTouch 4G | iPad Air 2
  • So es gibt eine erste funktionierende Variante.
    Kernveraenderungen:
    - Nur noch 3 Devices
    - Jedes device hat eigene Settings
    - Jedes device hat entsprechend eine eigene Sendeeinheit
    - Dadurch besseres balancing
    - Jedes device kann auch waehrend des Spiels pausiert werden, um Einstellungen anzupassen
    - Natuerlich die Optik angepasst an die Homepage und App


    WICHTIG! Aktuelle Bugs WICHTIG!
    - Delayeinstellung wird erst nach Neustart uebernommen (Anzeige wird gesetzt, aber Einstellung nicht!)
    - Nur Project Cars und die Simbim Spiele (Race, GTR2, R3E) funktionieren sicher, AC und iRacing nicht!
    - Es koennen noch andere Probleme enthalten sein, deswegen ist es nur eine Testversion

    @Frank Pabst : Bitte noch keinen offiziellen Download draus machen :)
    Hier der Vorab-Download fuer mutige Tester:
    pcars-forum.de/attachment/1433…b8b0304b0fad562ba0295a5bc
    barzmobilesolutions.de

    Gaming and developing on:
    CPU: Intel i7 6700K | RAM: 32GB DDR4 | Graphics: Palit SuperJetstream GTX980 Ti | Storage: 2x512GB SSD
    Mobile development on:
    MacBook Pro 15,4"
    Racing Equipment:
    Wheel: G25 | Pedals: Fanatec Elite
    Testdevices for App development:
    Sony Xperia Z2 | Sony Xperia Z3 Tablet Compact | Nexus 9 | HTC Desire Z | iPodTouch 4G | iPad Air 2
  • Zusatz vom Fahren gerade:
    Sieht gut aus. Ich konnte mit einem einzelnen Geraet absolut keine Verzoegerung oder Lags feststellen, sieht also
    vielversprechend aus.

    Wenn eventuell ein paar Leute den Reader ebenfalls testen koennten waere das natuerlich hilfreich.
    Ansonsten bau ich die beiden anderen Spiele wieder mit ein, damit ich dann entsprechend moeglichst zeitnah
    das ganze als offizielle Version anbieten kann.
    barzmobilesolutions.de

    Gaming and developing on:
    CPU: Intel i7 6700K | RAM: 32GB DDR4 | Graphics: Palit SuperJetstream GTX980 Ti | Storage: 2x512GB SSD
    Mobile development on:
    MacBook Pro 15,4"
    Racing Equipment:
    Wheel: G25 | Pedals: Fanatec Elite
    Testdevices for App development:
    Sony Xperia Z2 | Sony Xperia Z3 Tablet Compact | Nexus 9 | HTC Desire Z | iPodTouch 4G | iPad Air 2
  • Der Download ist wohl beim Serverumzug vom Forum verloren gegangen.
    Ich hab leider die Variante nicht mehr zur Hand, da ich schon weiter dran gearbeitet hab
    und meine Version nicht mehr mit der App im aktuellen Zustand zusammenarbeitet.

    Das braucht beides ein Update, was ich aber die Tage dann herausbringen werde.
    barzmobilesolutions.de

    Gaming and developing on:
    CPU: Intel i7 6700K | RAM: 32GB DDR4 | Graphics: Palit SuperJetstream GTX980 Ti | Storage: 2x512GB SSD
    Mobile development on:
    MacBook Pro 15,4"
    Racing Equipment:
    Wheel: G25 | Pedals: Fanatec Elite
    Testdevices for App development:
    Sony Xperia Z2 | Sony Xperia Z3 Tablet Compact | Nexus 9 | HTC Desire Z | iPodTouch 4G | iPad Air 2
  • Bertzel schrieb:

    Ich würde das gerne testen, aber der Link funzt nicht.
    Ja sorry, das war mein Fehler, die Datei ist beim Server-Umzug verloren gegangen (versehentlich gelöscht).

    @Sebastian Barz kannst der Test-Reader bitte nochmal hochladen?
    Mobo: ASUS X99-E WS | CPU: Intel Core I7 5930K @ 4,5 GHz | GPU: Nvidia GTX 1080ti | RAM: 32GB DDR4 2400 | PSU: be quiet! Dark Power Pro P10 1200W
    Cooling: Custom watercooled CPU and GPU | HDD: 2 x Samsung 256 GB SSD | OS: Win10 64bit | Wheel: CSW V2 + Heusinkveld HE pro + TH8RS | Monitor: LG 34UM65

    Kein Support per PN oder E-mail! Anfragen bitte im Forum, dann haben alle was davon!
  • @Frank Pabst
    Macht ja nix, ich hab grad noch auf den unendlichen Weiten meiner Festplatte eine Variante gefunden,
    an der ich noch nich rumgewerkelt hab.

    Immer noch:
    - Nur mit pCars,Race07,R3E und GTR2 zu nutzen, AC und iRacing gehen nicht.
    Dateien
    barzmobilesolutions.de

    Gaming and developing on:
    CPU: Intel i7 6700K | RAM: 32GB DDR4 | Graphics: Palit SuperJetstream GTX980 Ti | Storage: 2x512GB SSD
    Mobile development on:
    MacBook Pro 15,4"
    Racing Equipment:
    Wheel: G25 | Pedals: Fanatec Elite
    Testdevices for App development:
    Sony Xperia Z2 | Sony Xperia Z3 Tablet Compact | Nexus 9 | HTC Desire Z | iPodTouch 4G | iPad Air 2
  • Also habe mir den neuen Reader geladen, sei es 64bit oder 32bit, aber beide laufen bei mir nicht richtig.

    Nach der Installation wird das bekannte Icon nicht angezeigt, nämlich nur ein Windows Ersatzicon.
    Die Verbindung von Gerät zum Reader und Game scheint zu funktionieren, da alles korrekt angezeigt wird.
    Aber sobald ich einen Track starte passiert nichts mehr. Die Drehzahl LED bleibt bei voll stehen und mir wird weiterhin der Leerlauf angezeigt, obwohl dem nicht so ist.

    Frage ob ich etwas falsch mache, was ich aber nicht meine, da es ja vorher auch rund lief.

    Desweiteren was mir vorher schon die ganze Zeit auffiel, der Schaltblitz über den ganzen Bildschirm wird erst richtig dargestellt, nachdem ich ihn jedes mal neu eingefügt habe, ansonsten nach Boxenstopp, Hauptmenü und sonstigen Unterbrechungen werden immer nur bestimmte Bereiche im Display rot, der Rest bleibt schwarz.

    Benutze momentan weiterhin den hier geposteten Reader, der läuft wie gewohnt.
  • Ich habe soeben auch 7EUR investiert. Habe anfangs keine Verbindung hinbekommen, aber das lag wohl an den shared Memory den ich nicht freigegeben habe. (Die Anleitung dazu ist recht versteckt auf deiner HP) Nach einem Neustart aller zugehörigen Programme ging es dann und ich konnte keine weiteren Probleme feststellen. Sieht alles sehr nice und einängig aus. Habe den aktuellen Reader von deiner HP geladen sowie die aktuellste Version im Android Playstore!

    P.S.: Das Symbol im Windows ist tatsächlich nur das ersatz Icon. Zumindest als Verknüpfung auf dem Desktop.
  • @sbXII
    Das das Icon nicht richtig genutzt wird musste ich auch schon feststellen, das konnte ich jetzt aber kurzfristig nicht mehr aendern.
    Die Exe und in der Taskleiste wird das richtige Icon angezeigt.
    Jetzt kommt das ABER: Du musst die App updaten! Der neue Reader funktioniert nur mit App version 2.1, nicht mit 2.0.
    Wenn der gewohnte Reader funktioniert, hast du das Appupdate noch nicht auf der Handy.

    @Matziking
    Danke, es ist schade, dass das shared memory default auf off gestellt ist.
    Mit default on koennte man sich viele Probleme sparen.
    Eventuell muss ich die Benennung auf der HP mal ueberdenken, ums eindeutiger zu machen.
    barzmobilesolutions.de

    Gaming and developing on:
    CPU: Intel i7 6700K | RAM: 32GB DDR4 | Graphics: Palit SuperJetstream GTX980 Ti | Storage: 2x512GB SSD
    Mobile development on:
    MacBook Pro 15,4"
    Racing Equipment:
    Wheel: G25 | Pedals: Fanatec Elite
    Testdevices for App development:
    Sony Xperia Z2 | Sony Xperia Z3 Tablet Compact | Nexus 9 | HTC Desire Z | iPodTouch 4G | iPad Air 2
  • @sbXII
    Sehr gut.
    Gegen die verschwindenden Hintergruende werd ich im naechsten Update was tun.
    Allerdings muss ich erst noch genau herausfinden woran das liegt.
    Ansonsten reicht auch das Layout zu wechseln auf eines, das keinen oder einen anderen Hintergrund nutzt.
    Dann wird er zurueckgesetzt und neu erstellt beim zurueckwechseln.
    barzmobilesolutions.de

    Gaming and developing on:
    CPU: Intel i7 6700K | RAM: 32GB DDR4 | Graphics: Palit SuperJetstream GTX980 Ti | Storage: 2x512GB SSD
    Mobile development on:
    MacBook Pro 15,4"
    Racing Equipment:
    Wheel: G25 | Pedals: Fanatec Elite
    Testdevices for App development:
    Sony Xperia Z2 | Sony Xperia Z3 Tablet Compact | Nexus 9 | HTC Desire Z | iPodTouch 4G | iPad Air 2
  • Der neue Reader startet bei mir leider gar nicht. Nach dem ausführen kommt nur die Windows Meldung: TelemetryReaderWpf funktioniert nicht mehr:

    Quellcode

    1. Dateien, die bei der Beschreibung des Problems hilfreich sind:
    2. C:\Users\Bertzel\AppData\Local\Temp\WER7418.tmp.WERInternalMetadata.xml
    3. C:\Users\Bertzel\AppData\Local\Temp\WER8D73.tmp.appcompat.txt
    4. C:\Users\Bertzel\AppData\Local\Temp\WER8D74.tmp.mdmp
    5. Lesen Sie unsere Datenschutzbestimmungen online:
    6. http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0407
    7. Wenn die Onlinedatenschutzbestimmungen nicht verfügbar sind, lesen Sie unsere Datenschutzbestimmungen offline:
    8. C:\Windows\system32\de-DE\erofflps.txt
  • Bitte bei Absturz nicht vor dem Spielstart auf Start klicken, das ist nicht notwendig.
    Und den TelemetryReader bei Problemen im Admin Modus starten.
    barzmobilesolutions.de

    Gaming and developing on:
    CPU: Intel i7 6700K | RAM: 32GB DDR4 | Graphics: Palit SuperJetstream GTX980 Ti | Storage: 2x512GB SSD
    Mobile development on:
    MacBook Pro 15,4"
    Racing Equipment:
    Wheel: G25 | Pedals: Fanatec Elite
    Testdevices for App development:
    Sony Xperia Z2 | Sony Xperia Z3 Tablet Compact | Nexus 9 | HTC Desire Z | iPodTouch 4G | iPad Air 2
  • Als Admin hab ich schon gestartet - bringt nix.
    Auf Start klicken kann ich sowieso nicht. Das Fenster vom Telemetry Reader öffnet sich gar nicht erst. Es kommt sofort die Fehlermeldung.
  • Also direkt bei der Installation? Wann hast du ihn denn runtergeladen und welche Version? Hier aus dem Forum?
    barzmobilesolutions.de

    Gaming and developing on:
    CPU: Intel i7 6700K | RAM: 32GB DDR4 | Graphics: Palit SuperJetstream GTX980 Ti | Storage: 2x512GB SSD
    Mobile development on:
    MacBook Pro 15,4"
    Racing Equipment:
    Wheel: G25 | Pedals: Fanatec Elite
    Testdevices for App development:
    Sony Xperia Z2 | Sony Xperia Z3 Tablet Compact | Nexus 9 | HTC Desire Z | iPodTouch 4G | iPad Air 2
  • Habe gerade die aktuelle Version von barzmobilesolutions.de geladen.
    Installation läuft erfolgreich durch. Wenn ich dann die exe starte kommt keine Fenster hoch, sondern nur die Fehlermeldung.
    Hatte vorher noch eine alte Version drauf und nur die neue drüber installiert. (update)

    Danach habe ich dann alles nochmal sauber deinstalliert und die aktuelle Version installiert, hat aber leider nichts gebracht.
  • Hm ich hab jetzt extra nochmal alle Installer durchprobiert, aber konnte nirgends was feststellen.
    Bitte alles nochmal komplett deinstallieren. Neustarten und neu installieren.

    Welches Windows nutzt du?
    barzmobilesolutions.de

    Gaming and developing on:
    CPU: Intel i7 6700K | RAM: 32GB DDR4 | Graphics: Palit SuperJetstream GTX980 Ti | Storage: 2x512GB SSD
    Mobile development on:
    MacBook Pro 15,4"
    Racing Equipment:
    Wheel: G25 | Pedals: Fanatec Elite
    Testdevices for App development:
    Sony Xperia Z2 | Sony Xperia Z3 Tablet Compact | Nexus 9 | HTC Desire Z | iPodTouch 4G | iPad Air 2
  • Habe mir jetzt wieder 1.6 installiert, die läuft ohne Probleme. Allerdings scheint 1.6 nicht mit der aktuellen Hud Dash App zu laufen?! Hast du da noch eine ältere .apk für mich, die mit dem 1.6 reader läuft?
  • Und du hast die sowohl 32 als auch 64-bit varianten getestet?
    barzmobilesolutions.de

    Gaming and developing on:
    CPU: Intel i7 6700K | RAM: 32GB DDR4 | Graphics: Palit SuperJetstream GTX980 Ti | Storage: 2x512GB SSD
    Mobile development on:
    MacBook Pro 15,4"
    Racing Equipment:
    Wheel: G25 | Pedals: Fanatec Elite
    Testdevices for App development:
    Sony Xperia Z2 | Sony Xperia Z3 Tablet Compact | Nexus 9 | HTC Desire Z | iPodTouch 4G | iPad Air 2
  • Bertzel schrieb:

    Als Admin hab ich schon gestartet - bringt nix.
    Auf Start klicken kann ich sowieso nicht. Das Fenster vom Telemetry Reader öffnet sich gar nicht erst. Es kommt sofort die Fehlermeldung.
    Genau das selbe Problem hatte ich mit der Version 1.6, ob 64bit oder 32bit es kam nur eine Fehlermeldung, öffnen ließ es sich nicht mehr.

    Habe es aber nicht erwähnt, da am gleichen Tag die Testversion von Post 9 kam und damit lief es wieder rund. Seitdem keine Probleme mehr mit dem Reader!